登录  免费注册
当前位置:首页 > 漏洞详细信息

Apache Struts2存在S2-045远程代码执行漏洞

 关注(0)  
CNVD-ID CNVD-2017-02474
公开日期 2017-03-07
危害级别 高 (AV:N/AC:L/Au:N/C:C/I:C/A:C)
影响产品 Apache struts >=2.3.5,<=2.3.31
Apache struts >=2.5,<=2.5.10
CVE ID CVE-2017-5638
漏洞描述 Apache Struts是一款用于创建企业级Java Web应用的开源框架。

Apache Struts2存在S2-045远程代码执行漏洞。远程攻击者利用该漏洞可直接取得网站服务器控制权。
漏洞类型 通用型漏洞
参考链接 https://cwiki.apache.org/confluence/display/WW/S2-045
http://0day5.com/archives/4334/
漏洞解决方案 Apache Struts官方已在发布的新的版本中修复了该漏洞。建议使用Jakarta Multipart parser模块的用户升级到Apache Struts版本2.3.32或2.5.10.1:
https://cwiki.apache.org/confluence/display/WW/S2-045
厂商补丁 Apache Struts2存在S2-045远程代码执行漏洞的补丁
验证信息 已验证
报送时间 2017-03-07
收录时间 2017-03-07
更新时间 2017-03-08
漏洞附件 (无附件)
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD) | 已有0条评论
登录 后才能发表评论