登录  免费注册
当前位置:首页 > 漏洞详细信息

Jackson框架enableDefaultTyping方法反序列化漏洞

 关注(0)  
CNVD-ID CNVD-2017-04483
公开日期 2017-04-15
危害级别 高 (AV:N/AC:L/Au:N/C:C/I:C/A:C)
影响产品 Jackson Jackson 2.7.*,<2.7.10
Jackson Jackson 2.8.*,<2.8.9
漏洞描述 Jackson是一个开源的java序列化与反序列化工具,可以将java对象序列化为xml和json格式的字符串或将俩种文件反序列化为相应的对象。

Jackson框架enableDefaultTyping方法存在Java反序列化代码执行漏洞,攻击者利用漏洞可在服务器主机上执行任意代码或系统指令,取得网站服务器的控制权。
参考链接
漏洞解决方案 漏洞已上报给jackson,该开源组件已修复漏洞,使用该开源组件的应用需要更新jackson的jar包:
https://github.com/FasterXML/jackson-databind/issues/1599
厂商补丁 Jackson框架存在Java反序列化代码执行漏洞的补丁
验证信息 已验证
报送时间 2017-04-15
收录时间 2017-04-17
更新时间 2017-05-04
漏洞附件 附件暂不公开
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD) | 已有1条评论

评论 已有1条评论

2017-05-04 15:16:49 lvany lvany
Jackson 2.4版本是否受此漏洞影响? 回复
登录 后才能发表评论