登录  免费注册
当前位置:首页 > 漏洞详细信息

Apache Struts(S2-048)远程命令执行漏洞

 关注(0)  
CNVD-ID CNVD-2017-13259
公开日期 2017-07-08
危害级别 高 (AV:N/AC:L/Au:N/C:C/I:P/A:P)
影响产品 Apache struts 2.3.x
BUGTRAQ ID 99484
CVE ID CVE-2017-9791
漏洞描述 Apache Struts是一款用于创建企业级Java Web应用的开源框架。

Apache Struts2 2.3.x版本中存在S2-048远程代码执行漏洞。该漏洞存在Struts2和Struts1一个Showcase插件Action Message类中,攻击者可通过构建不可信的输入实现远程命令攻击。
参考链接 https://cwiki.apache.org/confluence/display/WW/S2-048
漏洞解决方案 官方已经发布了版本更新,建议用户升级到Struts 2.5.10.1版本,下载链接如下所示:
https://github.com/apache/struts/releases/tag/STRUTS_2_5_10_1
http://struts.apache.org/download.cg i
厂商补丁 Apache Struts(S2-048)远程命令执行漏洞的补丁
验证信息 (暂无验证信息)
报送时间 2017-07-07
收录时间 2017-07-08
更新时间 2017-07-08
漏洞附件 (无附件)
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD) | 已有0条评论
登录 后才能发表评论