登录  免费注册
当前位置:首页 > 补丁具体信息

Apache Hive Hive EXPLAIN查询未授权漏洞的补丁

2018-11-09| 补丁编号:CNPD-2018-144339| 贡献者:CNVD
所属漏洞编号 CNVD-2018-22937
补丁链接 https://hive.apache.org/downloads.html
补丁描述 Apache Hive是美国阿帕奇(Apache)软件基金会的一套基于Hadoop(分布式系统基础架构)的数据仓库软件。该软件提供了一个数据集成方法和一种高级的查询语言,以支持在Hadoop上进行大规模数据分析。 Apache Hive 2.3.3和3.1.0及之前的版本中存在安全漏洞,该漏洞源于Hive‘EXPLAIN’操作未能正确验证查询的权限。攻击者可利用该漏洞对任意表或视图执行‘EXPLAIN’并泄露表元数据和统计信息。目前,供应商发布了安全公告及相关补丁信息,修复了此漏洞。
补丁附件 (无附件)
补丁状态 通过审核
补丁审核意见 (无审核意见)
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD)