登录  免费注册
当前位置:首页 > 漏洞详细信息

WordPress $_SERVER变量跨站脚本漏洞

 关注(0)  
CNVD-ID CNVD-2007-7025
公开日期 2007-12-15
危害级别 中 (AV:N/AC:L/Au:N/C:N/I:P/A:N)
影响产品 WordPress teachPress 2.3.2
BUGTRAQ ID 26885
漏洞描述 WordPress是一款免费的论坛Blog系统。WordPress处理全局变量时存在漏洞,远程攻击者可能利用此漏洞控制导致跨站脚本执行攻击。WordPress信任了$_SERVER['REQUEST_URI']全局变量,因此远程攻击者控制了$_SERVER['REQUEST_URI']就可以执行跨站脚本攻击。以下是/wp-includes/query.php文件中第34行的有漏洞函数:function is_admin () { global $wp_query; return ($wp_query->is_admin || (stripos($_SERVER['REQUEST_URI'], 'wp-admin/') !== false));}该文件的第645行也存在同样的错误。
漏洞类型 通用型漏洞
参考链接 http://marc.info/?l=bugtraq&m=119774570706847&w=2
漏洞解决方案 临时解决方法:* 启用面向搜索引擎(SEF)url。厂商补丁:WordPress---------目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:http://wordpress.org/
厂商补丁 (无补丁信息)
验证信息 已验证
报送时间 2007-12-13
收录时间 2007-12-15
更新时间 2007-12-15
漏洞附件 (无附件)
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD) | 已有0条评论
登录 后才能发表评论