登录  免费注册
当前位置:首页 > 漏洞详细信息

Apache Synapse存在远程代码执行漏洞

 关注(0)  
CNVD-ID CNVD-2017-36700
公开日期 2017-12-11
危害级别 高 (AV:N/AC:M/Au:N/C:C/I:C/A:C)
影响产品 Apache Synapse <3.0.1
CVE ID CVE-2017-15708
漏洞描述 Apache Synapse是一个简单的、高质量开放源代码的替代方法,为实现 SOA 提供了一种途径,它可以公开现有的应用程序,而无需重新编写任何代码。

Apache Synapse存在远程代码执行漏洞,该漏洞源于Apache Commons Collections库包含“functor”包中的各个类可被序列化所致。攻击者可以通过注入特制的序列化对象,并在其类路径中包含Apache Commons Collections库,且不执行任何类型的输入验证,导致可远程执行代码。
漏洞类型 通用型漏洞
参考链接 http://www.openwall.com/lists/oss-security/2017/12/10/4?from=timeline
https://commons.apache.org/proper/commons-collections/security-reports.html
漏洞解决方案 Apache Synapse官方已经发布了最新的3.0.1版本修复了该漏洞,请受影响的用户尽快升级到最新版本:
http://synapse.apache.org/download/3.0.1/download.cgi

厂商补丁 Apache Synapse远程代码执行漏洞的补丁
验证信息 (暂无验证信息)
报送时间 2017-12-11
收录时间 2017-12-11
更新时间 2018-04-13
漏洞附件 附件暂不公开
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD) | 已有0条评论
登录 后才能发表评论