登录  免费注册
当前位置:首页 > 漏洞详细信息

Apache Thrift越界读取漏洞

 关注(0)  
CNVD-ID CNVD-2019-41289
公开日期 2019-11-19
危害级别 中 (AV:N/AC:L/Au:N/C:N/I:N/A:P)
影响产品 Apache Thrift >=0.9.3,<=0.12.0
CVE ID CVE-2019-0210
漏洞描述 Apache Thrift是一种接口定义语言和二进制通信协议,用于为多种语言定义和创建服务。

Apache Thrift存在越界读取漏洞。攻击者可通过无效输入数据利用该漏洞导致使用TJSONProtocol或TSimpleJSONProtocol以Go语言实现的服务器出现panic异常。
漏洞类型 通用型漏洞
参考链接 http://mail-archives.apache.org/mod_mbox/thrift-dev/201910.mbox/%3C277A46CA87494176B1BBCF5D72624A2A%40HAGGIS%3E
漏洞解决方案 厂商已发布了漏洞修复程序,请及时关注更新:
http://www.apache.org/dyn/closer.cgi?path=/thrift/0.13.0/thrift-0.13.0.tar.gz
厂商补丁 Apache Thrift越界读取漏洞的补丁
验证信息 (暂无验证信息)
报送时间 2019-10-29
收录时间 2019-11-19
更新时间 2019-11-19
漏洞附件 (无附件)
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD) | 已有0条评论
登录 后才能发表评论