登录  免费注册
当前位置:首页 > 漏洞详细信息

libmysofa栈缓冲区溢出漏洞(CNVD-2020-02452)

 关注(0)  
CNVD-ID CNVD-2020-02452
公开日期 2020-01-16
危害级别 中 (AV:N/AC:L/Au:N/C:N/I:N/A:P)
影响产品 libmysofa libmysofa 0.9.1
CVE ID CVE-2020-6860
漏洞描述 libmysofa是一款用于读取AES SOFA文件的库。

libmysofa 0.9.1版本中的hdf/dataobject.c文件的‘readDataVar’函数存在缓冲区溢出漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
漏洞类型 通用型漏洞
参考链接 https://nvd.nist.gov/vuln/detail/CVE-2020-6860
漏洞解决方案 厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/hoene/libmysofa/commit/c31120a4ddfe3fc705cfdd74da7e884e1866da85
厂商补丁 libmysofa栈缓冲区溢出漏洞(CNVD-2020-02452)的补丁
验证信息 (暂无验证信息)
报送时间 2020-01-13
收录时间 2020-01-16
更新时间 2020-01-16
漏洞附件 (无附件)
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD) | 已有0条评论
登录 后才能发表评论