登录  免费注册
当前位置:首页 > 漏洞详细信息

PHP授权问题漏洞

 关注(0)  
CNVD-ID CNVD-2020-10433
公开日期 2020-02-19
危害级别 中 (AV:N/AC:L/Au:N/C:P/I:N/A:N)
影响产品 PHP Heartland & Global Payments PHP SDK <2.0.0
CVE ID CVE-2019-20455
漏洞描述 PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHPGroup和开放源代码社区的共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。

Heartland & Global Payments PHP SDK 2.0.0之前版本中的Gateways/Gateway.php文件存在授权问题漏洞。攻击者可利用该漏洞获取网站敏感信息。
漏洞类型 通用型漏洞
参考链接 https://nvd.nist.gov/vuln/detail/CVE-2019-20455
漏洞解决方案 目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/globalpayments/php-sdk/releases/tag/2.0.0
厂商补丁 PHP授权问题漏洞的补丁
验证信息 (暂无验证信息)
报送时间 2020-02-17
收录时间 2020-02-19
更新时间 2020-02-19
漏洞附件 (无附件)
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD) | 已有0条评论
登录 后才能发表评论