登录  免费注册
当前位置:首页 > 漏洞详细信息

IXP EasyInstall操作系统命令注入漏洞

 关注(0)  
CNVD-ID CNVD-2020-11485
公开日期 2020-02-21
危害级别 低 (AV:L/AC:L/Au:N/C:C/I:C/A:C)
影响产品 IXP IXP EasyInstall 6.2.13723
CVE ID CVE-2019-19897
漏洞描述 IXP EasyInstall是用来下载安装python的一个第三方库管理工具,通过这个工具可以很方便的对Python中的第三方库进行管理。

IXP EasyInstall6.2.13723版本存在操作系统命令注入漏洞。该漏洞与受影响版本在外部输入数据构造操作系统可执行命令过程中未能正确过滤其中的特殊字符有关。可以通过TCP端口20051与代理服务进行通信,并通过使用“执行命令行”功能在目标系统的NT AUTHORITY SYSTEM上下文中执行代码。未经身份验证的攻击者可利用该漏洞执行非法操作系统命令。
漏洞类型 通用型漏洞
参考链接 https://nvd.nist.gov/vuln/detail/CVE-2019-19897
漏洞解决方案 厂商已发布了漏洞修复程序,请及时关注更新:
https://improsec.com/tech-blog/multiple-vulnerabilities-in-easyinstall-rmm-and-deployment-software
厂商补丁 IXP EasyInstall操作系统命令注入漏洞的补丁
验证信息 (暂无验证信息)
报送时间 2020-02-19
收录时间 2020-02-21
更新时间 2020-02-21
漏洞附件 (无附件)
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD) | 已有0条评论
登录 后才能发表评论