登录  免费注册
当前位置:首页 > 漏洞详细信息

Bitcoind/Bitcoin-Qt penny-flooding保护机制安全漏洞

 关注(0)  
CNVD-ID CNVD-2020-46868
公开日期 2020-08-20
危害级别 中 (AV:N/AC:L/Au:N/C:P/I:N/A:P)
影响产品 Bitcoin bitcoin * - 0.4.8rc4
漏洞描述 Bitcoin(比特币)是Bitcoin基金会的一种用开源的P2P软件开发的电子货币、数字货币,是一种网络虚拟货币。
bitcoind和Bitcoin-Qt 0.4.9rc1之前版本,0.5.8rc1之前的0.5.x版本,0.6.0.11rc1之前的0.6.0版本,0.6.1至0.6.5rc1之前的0.6.5版本,0.7.3rc1之前的0.7.x版本中的CTxMemPool::accept方法中的penny-flooding保护机制中存在漏洞。通过一系列大量的费用不足的Bitcoin事务,远程攻击者利用该漏洞确定钱包地址和IP地址之间的关系。
漏洞类型 通用型漏洞
参考链接 https://en.bitcoin.it/wiki/CVEs
https://bitcointalk.org/?topic=135856
漏洞解决方案 目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://en.bitcoin.it/wiki/CVEs
厂商补丁 (无补丁信息)
验证信息 (暂无验证信息)
报送时间 2020-08-19
收录时间 2020-09-14
更新时间 2020-11-04
漏洞附件 附件暂不公开
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD) | 已有0条评论
登录 后才能发表评论