登录  免费注册
当前位置:首页 > 漏洞详细信息

serialize-javascript代码问题漏洞

 关注(0)  
CNVD-ID CNVD-2020-53801
公开日期 2020-09-24
危害级别 中 (AV:N/AC:M/Au:N/C:P/I:P/A:P)
影响产品 Verizon serialize-javascript <3.1.0
CVE ID CVE-2020-7660
漏洞描述 Verizon serialize-javascript是美国威瑞森电信(Verizon)公司的一款支持将JavaScript序列化为 JSON超集的软件包。

serialize-javascript 3.1.0之前版本中存在代码问题漏洞。远程攻击者可借助index.js文件中的‘deleteFunctions’函数利用该漏洞注入任意代码。
漏洞类型 通用型漏洞
参考链接 https://nvd.nist.gov/vuln/detail/CVE-2020-7660
漏洞解决方案 目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/yahoo/serialize-javascript/commit/f21a6fb3ace2353413761e79717b2d210ba6ccbd
厂商补丁 serialize-javascript代码问题漏洞的补丁
验证信息 (暂无验证信息)
报送时间 2020-06-02
收录时间 2020-09-24
更新时间 2020-09-24
漏洞附件 (无附件)
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD) | 已有0条评论
登录 后才能发表评论