登录  免费注册
当前位置:首页 > 补丁具体信息

GNU Bash远程代码执行漏洞的补丁

2014-09-28| 补丁编号:CNPD-2014-50457| 贡献者:CNVD
所属漏洞编号 CNVD-2014-06345
补丁链接 http://www.gnu.org/software/bash/
补丁描述 GNU Bash(Bourne again shell)是一个命令语言解释器,能够从标准输入设备或文件读取、执行命令,结合部分ksh 和csh特点,同时也执行IEEE POSIX Shell(IEEE Working Group 1003.2)规范。 GNU Bash 4.3及之前版本存在安全漏洞,可能导致cgi程序在服务器上发送恶意的http请求,允许攻击者利用漏洞执行任意代码。该漏洞产生的原因是bash在完成函数定义后并未退出,而是继续解析并执行shell命令,导致漏洞产生严重后果。目前,供应商发布了安全公告及相关补丁信息,修复了此漏洞。
补丁附件 (无附件)
补丁状态 通过审核
补丁审核意见 (无审核意见)
  在发布漏洞公告信息之前,CNVD都力争保证每条公告的准确性和可靠性。然而,采纳和实施公告中的建议则完全由用户自己决定,其可能引起的问题和结果也完全由用户承担。是否采纳我们的建议取决于您个人或您企业的决策,您应考虑其内容是否符合您个人或您企业的安全策略和流程。
(编辑:CNVD)