登录  免费注册
当前位置:首页 > 安全公告 > 正文

关于Linux Kernel存在本地权限提升漏洞的安全公告

2017-02-24 14:22:50
安全公告编号:CNTA-2017-0014

近日,国家信息安全漏洞共享平台(CNVD)收录了Linux kernel两个本地权限提升漏洞(CNVD-2017-01870,CNVD-2016-11972对应CVE-2017-6074、CVE-2016-8655)。本地攻击者利用漏洞可提升权限,发起进一步攻击。

一、漏洞情况分析

Linuxkernel是美国Linux基金会发布的操作系统Linux所使用的内核。DCCP(数据报拥塞控制协议)是面向消息的传输层协议,其尽可能最小化分组报头大小或端节点处理的开销,并且提供不可靠分组流的建立,维护和拆卸以及该分组流的拥塞控制。

安全研究人员在DCCP实现中使用Syzkaller(Google发布的内核模糊测试工具)发现 了十多年前的Linux KernelBug(CVE-2017-6074)。 该漏洞是一个“Use-After-Free”漏洞(内存数据破坏缺陷),内核中net/dccp/input.c文件的dccp_rcv_state_process函数存在安全漏洞,由于程序未能正确处理DCCP_PKT_REQUEST数据结构。本地攻击者可借助IPV6_RECVPKTINFOsetsockopt系统调用的应用程序,利用该漏洞更改Linux内核内存,导致拒绝服务(系统崩溃)或获取系统上的管理访问权限。

在两个月前在Linux内核中发现了一个类似的特权提升漏洞(CVE-2016-8655),该漏洞可追溯到2011年,由于创建AF-PACKET套接字时,网络命名空间中需要CAP_NET_RAW,在低权限命名空间可用的系统中(Ubuntu、Fedora等)可通过未授权进程获取。本地攻击者利用漏洞可在内核中执行任意代码,导致拒绝服务条件,或以管理员权限执行任意代码。

CNVD对上述漏洞技术评级为“高危”。

二、漏洞影响范围

CNVD-2017-01870漏洞影响的版本为Linux kernel 4.9.11及以前的版本,影响Linux操作系统的主要发行版,包括Redhat,Debian,OpenSUSE和Ubuntu.厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/torvalds/linux/commit/5edabca9d4cff7f1f2b68f0bac55ef99d9798ba4

CNVD-2016-11972漏洞影响范围:Linux内核(2011年4月19日发行)开始受影响,直到2016年11月30日修复。厂商提供漏洞修补链接如下:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=84ac7260236a49c79eede91617700174c2c19b0c

附:参考链接:

http://thehackernews.com/2017/02/linux-kernel-local-root.html?m=1

https://bugzilla.redhat.com/show_bug.cgi?id=1400019

http://www.cnvd.org.cn/flaw/show/CNVD-2017-01870

http://www.cnvd.org.cn/flaw/show/CNVD-2016-11972


(编辑:CNVD) | 已有0条评论
登录 后才能发表评论
已有0条评论