登录  免费注册
当前位置:首页 > 安全公告 > 正文

关于Western Digital My Cloud NAS设备存在高危漏洞的安全公告

2018-01-06 12:56:44
安全公告编号:CNTA-2018-0003

1月5日,国家信息安全漏洞共享平台(CNVD)收录了6起Western Digital My Cloud NAS设备高危漏洞,包括:Western Digital My Cloud NAS设备信息泄露漏洞(CNVD-2018-00399)、Western Digital My Cloud NAS设备拒绝服务漏洞(CNVD-2018-00400)、Western Digital My Cloud NAS设备跨站请求伪造漏洞(CNVD-2018-00402)、Western Digital My Cloud NAS设备命令注入漏洞(CNVD-2018-00401)、Western Digital My Cloud NAS设备无限制文件上传漏洞(CNVD-2018-00403)、Western Digital My Cloud NAS设备硬编码后门漏洞(CNVD-2018-00404)。综合利用上述漏洞,远程攻击者可发起拒绝服务器攻击、远程执行命令、获取My Cloud设备控制权。目前漏洞的修复方案尚未公布。

一、漏洞情况分析

Western Digital My Cloud NAS是一款应用广泛的网络连接云存储设备,可用于托管文件,并自动备份和同步该文件与各种云和基于Web的服务。此外,该设备不仅可让用户共享家庭网络中的文件,而且私有云功能还允许用户随时随地访问该文件数据。

CNVD-2018-00399:攻击者可通过向Web服务器发送一个简单的请求来转储所有用户的列表,包括详细的用户信息,而不需要任何身份验证,如:GET /api/2.1/rest/users? HTTP/1.1

CNVD-2018-00400:该漏洞是由于未经身份验证的用户可为整个存储设备及其所有用户设置全局语言首选项所致,攻击者可能会恶意利用该功能导致Web界面拒绝服务。

CNVD-2018-00402:该漏洞是由于WD My Cloud网页界面中无有效地XSRF保护所致,攻击者可利用任何恶意网站使受害者的网络浏览器连接到网络上的My Cloud设备,诱使目标用户进行访问,获取My Cloud设备控制权。

CNVD-2018-00401:该注入漏洞可能与跨站点请求伪造XSRF漏洞相结合,导致攻击者获得受影响设备的完全控制权(root访问权限)。

CNVD-2018-00403:该漏洞是由于开发人员错误地实现了gethostbyaddr()PHP函数所致,漏洞存在于“multi_uploadify.php”脚本中。攻击者可使用参数Filedata[0]将任意恶意文件上传到互联网易受攻击的存储设备所在的运行服务器,以root身份获得远程shell。

CNVD-2018-00404:该漏洞是由于开发者将管理员用户名“mydlinkBRionyg”和密码“abc12345cba”,硬编码到二进制文件,且无法更改所致。攻击者可利用上述凭证登录到WDMy Cloud设备,注入命令,导致root shell。

CNVD对上述漏洞的综合评级为“高危”。

二、漏洞影响范围

受影响的云端固件版本和型号如下:

MyCloud<=2.30.165

MyCloud Mirror <=2.30.165

受影响的设备型号:

MyCloud Gen 2

MyCloud PR2100

MyCloud PR4100

MyCloud EX2 Ultra

MyCloud EX2

MyCloud EX4

MyCloud EX2100

MyCloud EX4100

MyCloud DL2100

MyCloud DL4100

三、处置措施

目前,厂商暂无详细的解决方案: https://www.wdc.com/region-selector/splash-region.html

附:参考链接:

https://thehackernews.com/2018/01/western-digital-mycloud.html

POC:

https://dl.packetstormsecurity.net/1801-exploits/GTSA_wdmycloud_backdoor.rb.txt

(编辑:CNVD) | 已有0条评论
登录 后才能发表评论
已有0条评论