登录  免费注册
当前位置:首页 > 安全公告 > 正文

关于Chrome浏览器WebSQL和SQLite存在任意代码执行漏洞的安全公告

2019-12-19 13:40:49
安全公告编号:CNTA-2019-0040

2019年12月,国家信息安全漏洞共享平台(CNVD)收录了由腾讯安全平台部Tencent Blade Team发现并报告的多个Chrome浏览器WebSQL组件和SQLite远程代码执行漏洞(CNVD-2019-45908,对应CVE-2019-13734, CVE-2019-13750,CVE-2019-13751, CVE-2019-13752, CVE-2019-13753)。攻击者利用该漏洞,通过社工手段诱使用户访问恶意网页,实现对用户浏览器网页进程的权限控制和代码执行。目前谷歌公司、SQLite已发布补丁完成修复。

一、漏洞情况分析

SQLite是由D.RichardHipp建立的一个开源关系数据库,该数据库兼容ACID,具有多语言支持、零配置、轻量化、执行效率高的特点,在网页浏览器、操作系统、嵌入式系统中得到了广泛使用。Chrome是一款由Google开发的浏览器,提供了由SQLite数据库支持的WebSQL功能,支持网页脚本对SQL语句的执行。

2019年12月,国家信息安全漏洞共享平台(CNVD)收录了由腾讯安全平台部Tencent Blade Team发现并报告的多个SQLite、Chrome浏览器WebSQL组件远程代码执行漏洞。由于SQLite表结构在处理过程中时,存在多个逻辑漏洞和内存破坏漏洞,导致Chrome浏览器WebSQL、SQLite存在任意代码执行漏洞。攻击者利用该漏洞,通过钓鱼邮件、恶意短信等社工手段诱使用户访问恶意网页,在支持外部输入SQL语句和使用SQLite组件的软件上实现代码执行,在Chrome浏览器和基于Chromium开发的浏览器上实现Render权限的任意代码执行。

CNVD对该漏洞的综合评级为“高危”。

二、漏洞影响范围

根据官方公告情况,该漏洞影响的产品和版本如下:

1、Chrome浏览器79.0.3945.79以下版本

2、使用Chromium内核(79.0.3945.79以下)的浏览器

3、使用SQLite官方版本且未更新2019年12月4日补丁(e01fdbf9)的SQLite组件

三、漏洞处置建议

1、谷歌官方已发布补丁修复此漏洞,CNVD建议使用Chrome浏览器的用户立即升级至最新版本:

https://www.google.cn/intl/zh-CN/chrome/

2、使用Chromium内核开发的浏览器厂商,需将内核版本更新至官方稳定版79.0.3945.79以上。用户也可采取禁用WebSQL模块或单独合入补丁等临时防护措施。

3、将SQLite组件更新至2019年12月4日及之后的补丁。

附参考链接:

https://chromereleases.googleblog.com/2019/12/stable-channel-update-for-desktop.html

https://www.sqlite.org/src/info/e01fdbf9f700e1bd


感谢腾讯安全平台部Blade Team对本公告提供的技术支持。

(编辑:CNVD) | 已有0条评论
登录 后才能发表评论
已有0条评论